GS850g Log



1982 Suzuki GS850G

1050x640 - 800x488

May 24th, 2003 - I just purchased this bike. I think it has a problem in the charging circuit, most likely grimy connections. It also refuses to idle when warm. Stay tuned, more when I get it running like it should.

May 27th, 2003 - Much better, an hour or so tinkering, a little sand paper work and the battery is seeing the 13 volts it is accustomed to. Now I just have to register the bike, get my license and ride, ride, ride. :)

May 29th, 2003 - Good news: the battery stays charged. Bad news: The idle problem remains. After riding for 15 minutes or so, the engine dies on idle. It runs fine otherwise and idles fine after cooling. Possibly the oil level is too high, it needs an oil change anyway.

May 30th, 2003 - Took apart and cleaned the left control, including the turn signal controls, in an effort to get the horns working again. I registered the bike today and get the title in my name, after taking the written motorcycle test. I only missed 2, meaning I passed. Just need the riding test now. The idle problem seems to have disppeared, haven't seen the problem again. Probably just needed the carbs blown out a bit. :)

May 31st, 2003 - Took out the air filter. Smelled pretty gassy and was pretty heavy with oil and gunk. The foam is starting to get bad in couple of places, but not bad enough to replace yet. Took apart the right brake lever to grease the handle. I originally just wanted to adjust the lever a little, but there's no adjustment for that. The grease helped enough. Had to clean and adjust the rear brake switch as well.

June 1st, 2003 - Got the air filter reinstalled after cleaning and oiling (thanks John!). Seems to be running fine. Both pipes rattle a bit, probably the baffles (nod to John). I'll probably replace them next year.

July 17th, 2003 - Been a while since the last update, but I've busy riding! Changed the oil and filter, the old oil didn't reveal any problems in its dark depths. I got a new tach cable installed, the old inner cable was in four pieces! The carbs need some attention, rolling off idle is a little rough at times. Other than that, been several hundred miles logged bumming around Iowa. Changed the oil at 21770, has 22231 now. :) The idle problem just kind of disappeared after the last incident. Put on some new hand grips, some modern Pro Grip jellies, they feel pretty good compared to the old ones.


April 6th, 2004 - Fall, Winter, and finally Spring. I stored the bike over the winter in a shed of a friend of mine (Thanks Carl!). I was good; I took out the battery. I was bad; I didn't drain the bowls or put anything in the tank to stabilize the fuel. I was resigned to gelled carbs and fuel lines. Fortune smiled on me, however; after running through 2 semi dead batteries (the original and an old car battery I'd brought just in case) AND a jump from a good car battery, the bike roared to life. It was a little chilly towards the end of the ride back to Williamsburg, fortunately I had invested in a leather jacket over the winter. All I need is a new battery and some decent gloves and I'll be all set to run until Fall.


2015 - Realized the "end" of story is missing. At a time I no longer recall, maybe 2009, 2010, I stored the bike in my father's garage. This was just after replacing the starter with a used one from ebay. Failure, the petcock started leaking gas, was shut off. Yep, in late winter or early spring, noted this, knew carbs likely dried out and start failed. Tried to fiddle a bit, but clear petcock needed replaced among other things. And so it has sat, in my father's garage, waiting for attention, parts and repair work. One of these days....

Yow, mail archive check indicates 2007 was the stop of motion for the bike. EIGHT years?!? Yikes!!.



wkks.org -> Bill's Room -> Motorcycles